Mike McBike @ Home / Arcade Reparaturberichte / Frogger Reparatur


{Fehlerbeschreibung} Frogger - ein wahrer Klassiker. Diesen hier habe ich als Kompensation für meine Reparaturbemühungen erhalten, danke dafür. Eigentlich sollte er funktionieren, aber so genau weiss ich das noch nicht... Erstmal einen Adapter basteln und dann sehen wir weiter.

Frogger


{Diagnose} Ist ja interessant... beim ersten Einschalten lief Frogger perfekt, nach zwei, drei Spielen denn plötzlich: Spritesalat... :-(
Genauer gesagt: die Sprites funktionieren noch, die Frösche hüpfen, aber anstatt der richtigen Tiles werden plötzlich flackernde Textzeichen dargestellt, die sich auf dem Bildschirm bewegen. Es ist mir das erte Mal pessiert, dass ein Spiel unterm Spielen den Geist aufgibt. Ein Wackelkontakt ist es übrigens nicht, der Zustand ist erstaunlich stabil.

Screenshot


{Fortsetzung...} Google ist mein Freund: Aussiarcades Repair Log Frogger. Der hatte das schon mal und tatsächlich: es war ein defekter 2114. Eine ganz neue Erkenntnis: der Huckepacktest kann auch bei RAMs funktionieren:

RAM Huckepack

Screenshot

Screenshot

Ach was hab' ich mich gefreut...

Messplatz

erledigt


{Ernüchterung} Und dann kam, was kommen musste: eine Stunde Dauerlauf und schon schreckt mich ein "Piep" aus den Gedanken... Aus den Augenwinkeln sehe ich, wie die Frogger resettet... ohje... Und resettet... und resettet... und resettet... Mist. Nächstes Teil kaputt.

Das Oszi zeigt: Z80 läuft an und versucht den Videospeicher zu löschen, bleibt stehen und schon schlägt der Watchdog zu. Immer wieder. Da es sonst keine verdächtigen Signale gibt und das Überbrücken des Watchdog zwar den Löschvorgang zu Ende bringt, dann aber zum Totalabsturz führt, habe ich das Program-RAM im Verdacht. Huckepack die zweite: voila, wieder ein 2114 gestorben... Wie die Fliegen...

Nach dem Tausch läuft alles gut an. Aber was ist das: Text und Tiles sind gut, aber die Frosch-Sprites sind völlig an der falschen Stelle... ich könnte kotzen.

Programm-ROM

Voll daneben

Das Frogger Manual gibt Auskunft zu "misplaced frogs": die 74LS161 (voreinstellbare Dezimalzähler), die das Video-RAM adressieren könnten es sein. Also wieder flugs das Ozi angeworfen und die Zähler und Gatter danach funktionieren, aber der Lade-Impuls, der die voreingestellten Daten in die Zähler übernimmt, liefert ein "Low" bei 2V... das kann ja nicht gehen. Hier mal der Unterschied zwischen einem schlechten Signal und einem guten Signal. Man beachte die Lage des 0V-Pegels. Das ist nicht "low"!

Signale

Sodele, also flugs den Sender getauscht, nicht besser. Empfänger getauscht: nicht besser... jetzt gehts aber los! Also Leiterbahn verfolgt - und siehe da: es gibt Kurzschlüsse, die gibt es eigentlich garnicht... Wenn ich jetzt noch erzähle, dass ich beim Einlöten der Fassungen für die 74LS161 noch einen versteckten Kurzschluss fabriziert habe und alles noch schlechter ging, als vorher, lacht Ihr mich bestimmt aus, deshalb erzähl' ich das besser nicht. Auf jeden Fall geht die Frogger jetzt wieder prima!

Ach ja, und wer sich wundert, warum bei Frogger kein Sound rauskommt, der sollte sich das Manual gut durchlesen: auf der oberen Platine ist ein sechspoliger Stecker, der hätte gerne ein Lautstärkepoti... Ha. Ha.

Kurzschluss

Kurzschluss

Kurzschluss


© 2013 - 2014 · W. Robel e-Mail senden