Mike McBike @ Home / Arcade Reparaturberichte / Galaxian BL Reparatur


{Fehlerbeschreibung} zwei Galaxian Bootleg PCBs in traurigem Zustand...


{Diagnose(n)} Die Inbetriebnahme der "guten" Galaxian liefert das ernüchternde Ergebnis: Bild ja, aber Programm startet nicht (statische wirre Zeichen auf dem Schirm). Das sieht nicht gut aus. Ich entscheide mich für radikale Maßnahmen: die korrodierte PCB dient als Ersatzteilspender, die "gute" wird aufgebaut.
Ein neuer Z80 sorgt dafür, dass die Platine in den RAM Test geht, nur um dafür gleich mal RAM-Fehler (RAM 3 bad) zu melden. Die RAMs 3 (2101A) sind aber in Ordnung, also muss es an was anderem liegen... Der I/O Datenbus zeigt Signale 0V (Low) 4V (High) und erstaunlicher Weise 3V (mittel)... 74LS367 Buffer auf 5M ist defekt. Tausch... Yepp: RAM-Test läuft durch. Aber...:

Screenshot

Screenshot

Ich werd' noch irre... Alle Latches und Buffer auf dem Datenbus scheinen gut zu arbeiten, ich werde nicht herumkommen, alle Kandidaten auszulöten und zu ersetzen, da die mittleren Logikpegel immer noch vorhanden sind und das Beschreiben des Video-RAMs stören. Legt man den Finger auf das RAM, so kann man die lustigsten Effekte am Bidschirm zaubern, weil der 50Hz Netzbrumm den Logikpegel zufällig gerade mal so über die High-Schwelle hebt... Ach ja, Bootleg-Platinen sind extrem empfindlich, was das Auslöten mit dem Heißluftfön angeht... 350°C sind da schon fast zu heiß, das Glasfaserzeugs delaminiert irre schnell...

Wird fortgesetzt.


© 2013 - 2014 · W. Robel e-Mail senden