Mike McBike @ Home / Arcade Reps Teil 3 / Beast Busters


{Beast Busters mit Grafikproblemen} Neu und groß. Zwei Attribute, die ich garnicht mag...

PCB 1

PCB 2

PCB 3

Ein großes Monster mit vielen Customs und drei Platinen gestapelt. Trotzdem irgendwie Reparatur-freundlich. Also erstmal einen Adapter bauen, der alles hat, was man braucht: R/G/B/S/5V/GND

Adapter

Adapter


{Analyse} Das Spiel startet im ersten Augenblick ohne jeden Fehler, ich denke schon "Was will er von mir?", doch da ist es vorbei mit der Freude: Streifen bilden sich auf dem Schirm... Geil-gruselige Grafik übrigens!

Screenshot

Screenshot

Screenshot

Screenshot

Screenshot

Screenshot


{Analyse 2} Gewalt an den Flachbandkabeln führt kurzzeitig zu massiven Problemen am Text-Layer... da war aber der Stecker nicht richtig drin...

Screenshot

Screenshot


{Reparatur} Fassen wir zusammen: kein Schaltplan verfügbar, Grafik-Custom-Chips überall, aber wenigstens normale RAMs und ROMs. Ich finde zumindest mal am Video-Ausgang ein RAM, welches auf der Hälfte der Datenleitungen fast keine Signale hat. Das könnte ein Hinweis sein. Also präventiv mal Bustreiber und ROM tauschen (Und ja, ich habe zu wenig 24polige Sockel und zu viele 6polige...)

Reparatur

Reparatur

Leider ändert das nichts an der Situation. Auch ein gezieltes Kühlen mit einer halben Dose Kältespray ändert nichts... Fortsetzung folgt.


{Reparatur} Habe zusammen mit meiner Tochter als Lehrling weiter gesucht:

PCBs

Zuerst war das Bild wieder super, aber langsam schleichen sich von oben wieder Grafikartefakte ein, die nicht weggehen wollen. Sieht irgendwie nach einem Speicherfehler aus. Also auf zur mühsamen Suche nach Unregelmäßigkeiten in den Daten- und Adressbussen der Video-RAMs...

Screenshot

Screenshot

Screenshot

Screenshot

So darf ein Datenbus nicht aussehen...

Datenbus

Datenbus

Gefunden habe ich den Zustand in einer der beiden GFX-Video-RAM-Sektionen... Vorgehensweise: alle Datenpins einzeln aboszillografieren. Den Bustreiber habe ich als Erstes getauscht. Der Fehler ist nicht weg, schade eigentlich...

Bustreiber

Dann also das Video-RAM ersetzen- und siehe da, die Grafikfehler sind weg, das RAM war defekt. Allerdings wird nur jedes zweite Bild dargestellt, das flimmert wie Sau... Folglich die daneben liegenden RAMs auch checken, eines war ebenso "komisch": auch ersetzt.

Video RAM

Video RAM

Schon klappt's mit den Sprites - Erfolg ist ein geiles Gefühl!

Screenshot

Screenshot

Screenshot

Da sind wohl mehrere Video-RAMs gestorben und eine "verbohrte" Single-Slot-MVS-Leiche hat mir als Spender gedient...

Spender


© 2013 - 2016 · W. Robel e-Mail senden