Mike McBike @ Home / Arcade Reps Teil 2 / Haunted Castle


{Fehlerbeschreibung} Eine Haunted Castle (Uäch... Konami Custom Hell...) mit korrupten Sprite-Grafiken

PCB

{Diagnose} Der Besitzer hatte bereits die Video-RAMs gewechselt, ein bekannter Fehler auf dieser Platine, die außerdem zu defekten Durchkontaktierungen neigt, die Dinger sind hier echt extrem klein... Der RAM-Tausch führte offensichtlich zu einer signifikanten Verschlechterung...

Screenshots

Screenshots

Screenshots

Screenshots


{Reparatur} Wenn man die Grafik-RAMs an den Beinchen berührt, ändert sich das Fehlerbild in "noch schlechter"... Das deutet auf nicht verbundene Signalleitungen hin. Ich vermaß die Signale an den Video-RAMs... Eine der Adressleitungen war dauernd Low, kein gutes Zeichen! Um herauszufinden, wo diese Adressleitung, die offensichtlich durch vorheriges unachtsames Auslöten unterbrochen worden war, im Custom verschwand, hoffte ich auf identisch aufgebaute Video-Einheiten und klingelte den "gesunden" Part durch.

Referenz

Schon war der Pin identifiziert. Nun mal probeweise den gleichen Pin auf der Nachbarseite mit dem dortigen RAM verbunden:

Reparatur

Juhu... schon klappt es auch wieder mit den Sprites.

Screenshots

Screenshots

Screenshots

Screenshots


{Reparatur Teil 2} Oh Mann, es wäre ja so schön gewesen, aber nach genauer Durchsicht zeigt sich, dass immer noch Sprites völlig fehlen: der Schriftzug im Titelbild, die Figuren am Anfang, fliegende Knochen und Steine... Also tausche ich auch noch die beiden anderen RAMs.

Reparatur 2

Reparatur 2

Reparatur 2

Reparatur 2

Juhu... schon klappt es auch wieder mit ALLEN Sprites.

Screenshots

Screenshots

Screenshots

Screenshots


© 2013 - 2014 · W. Robel e-Mail senden